Алгоритмическая структура "цикл" - rita.netnado.ru o_O
Главная
Поиск по ключевым словам:
страница 1
Похожие работы
Название работы Кол-во страниц Размер
Практическая работа №2 Алгоритмическая структура «ветвление» 3 Практическая... 1 124.25kb.
Выдержки из книги К. Титова и Н 1 45.93kb.
Структура мбоу пионерская сош 1 21.45kb.
Общая характеристика образовательного учреждения Состав воспитанников... 1 163.46kb.
Цикл гуманитарных и социально-экономических дисциплин 1 50.41kb.
Мы живем в эпоху больших перемен, быстро меняющегося мира. Меняется... 3 662.32kb.
Матрица анализа предложений по содержанию ооп гуманитарный, социальный... 3 454.7kb.
37. Механизм правового регулирования и его структура. 38. Основные... 1 15.27kb.
Вопросы к Госэкзамену для студентов, обучающихся по специальности... 18 2006.8kb.
Пояснение к программе. Цикл "Яйцо или курица" 7 1551.1kb.
Урок для учащихся 4-6 классов 1 116.05kb.
Программа развития сельский социо-культурный центр. Моу сош им. 1 273.35kb.
Публичный отчет о деятельности моу кассельская сош 2 737.71kb.
Алгоритмическая структура "цикл" - страница №1/1

Алгоритмическая структура "цикл".


В алгоритмическую структуру цикл входит серия команд, выполняемая многократно. Такая последовательность команд называется телом цикла.

Циклические алгоритмические структуры бывают двух типов:



  • цикл со счетчиком, в котором тело цикла выполняется определенное количество раз;

  • цикл по условию, в котором тело цикла выполняется, пока истинно условие.

Цикл со счетчиком

Алгоритмическая структура цикл со счетчиком используется, если известно заранее, какое число повторений тела цикла необходимо выполнить.



Запись команды цикла-счетчика на алгоритмическом языке:

нц число раз

| тело цикла



кц

Пример1.

Описать результат выполнения алгоритма:



алг Стежок

нач

| нц 10 раз

| вправо; закрасить; вправо

| кц



кон

Пример 2. Выполнить программу и нарисовать блок – схему.

алг Виражи

нач

| нц 4 раз

| | вправо

| | если клетка закрашена

| | | то вниз; вправо

| | | иначе вверх

| | все

| кц

кон

Цикл с условием.


Цикл с условием используется, когда заранее неизвестно, какое количество раз должно повториться тело цикла. В таких случаях количество повторений зависит от некоторого условия.

Цикл называется циклом с предусловием, если условие выхода из цикла стоит в начале, перед телом цикла. Цикл с предусловием может ни разу не выполниться, если условие окажется ложным.

нц пока условие

| тело цикла



кц

Цикл называется циклом с постусловием, если условие выхода из цикла стоит в конце, после тела цикла. Цикл с постусловием выполняется обязательно, как минимум, один раз, независимо от того, истинно условие или нет.

нц

| тело цикла



кц при условие

Практическая работа. Решение задач по карточкам